When I am upgrading PiP it gives me this error: An error occurred during configuration

Please help I am making a discord bot: https://replit.com/@Bearcat19/Discord

And it is giving me this error every time I am upgrading it An error occurred during configuration: option use-feature: invalid choice: ‘con tent-addressable-pool’ (choose from ‘fas t-deps’

)

‘truststore’.

'no-binary-enable

-wheel-cache’)
I tried to use this topics thing: Error after upgrading pip
It didn’t work and gave me a error

Pls help :frowning:

I’m using Python Btw

If you try to upgrade pip like that, you will always get this error( I know from experience). And as far as I know, the only fix is to create a new repl and move all the code. (In the future just update the python version)

Okay I’ll try thanks

1 Like

Hey sorry for the late response but the no content addressable pool error can be fixed with:

sed -i 6d .config/pip/pip.conf

1 Like

That worked! Thanks you!!

2 Likes

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.