Typing in editor does not update editor texts


When I type in the editor, the caret stays at the same place, while after typing, the changes are not updated to the text. Copy-pasting, replacing, and deleting lines work normally.

Replit Profile: https://replit.com/@darkcalm

I believe this thread may help you

1 Like

Please attach a screen recording so we can investigate

Interesting, I’ve never seen this happen before. Do you have any browser extensions installed that could be causing this?

If not, please invite ReplitIronclad to your Repl and ping me here so I can take a look

Yeah this happens to me sometimes, and it finally updates after around 30 seconds.

My editor also stops working/updating in this manner. Also, sometimes it won’t let me backspace beyond a variable number of spaces/tabs although I can add spaces and delete those. I close the repl and open it again, sometimes it starts working again. If I close the browser and log back in, it sometimes starts working again. I have tried different browsers including Firefox, Chrome, and Brave. I don’t know if it’s related but it started happening shortly after upgrading to try Ghostwriter.

Have you tried running kill 1 in the shell?

kill 1 works :partying_face: for now.

I’ll ping you if it persists afterwards.

1 Like

Welp, peace didn’t last long with kill 1. Invited.

I wasn’t able to reproduce the issue. I hopped into your Repl and reset the VM it’s running on so hopefully that will do some good :slight_smile:

1 Like

new information:

  • the issue on my end happens in app.js but not index.html or hello.py
  • texts by pasting in persists

Does closing all other tabs and apps on your device help?

Try reloading the page, does that fix the issue temporarily?

What device are you using, and in terms of performance how would you rate its speed? (1-10)

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.