Slow loading times for Teams projects

Bug description:
When open replit projects in Teams created by me or my students, there is a significant delay where the files don’t appear or load asynchronously and my students don’t see the file

Expected vs Current Behavior:
I pay for the Hacker plan. I was hoping this would cause project files to load instantaneously when they’re opened.

Steps to reproduce:
Clicking any project files in Teams

Bug appears at this link:

Screenshot(s)/Screen Recording:

Browser/OS/Device: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/ Safari/537.36

Replit Profile:


This is just one example of a student’s project taking 5-10min to load

Same problem here. Been that way for a couple of days now.

Same problem here since last week. It is causing issues while teaching.

Recently, I’ve been seeing many posts on slow downs in Replit’s Teacher IDE load times.
This is a reoccurring post, and is definitely being worked on by Replit staff!

I would say this will be fixed as soon as possible due to its large extent.

Since last Friday I am having issues with the replit projects on Teams. I have about 22 students and when trying to use it in class it is very slow. It does not load properly for many students and even for me.
When we use the personal replit it is working fine. Is there any known issue with this ?

I’ve been using Edu Teams for several years now. I love it, but recently I’ve been having a lot of headaches with it. A major one has been how long it takes for the repl’s to load for my students. This all began around Feb/Mar of 2023.


  • Students click an assignment and they stare at a “Repl booting” screen for several minutes.
  • When students are typing, the cloud (by the top left repl name) is flashing showing it’s “saving”. This also can take several minutes.

Things I’ve Tried

  • In April I’ve contacted our IT department and they confirmed they whitelisted the sites listed on the IT Admin’s Toolkit.
  • I’ve ensured browsers have been updated. This is an issue using safari, chrome, and firefox on all my machines. They are running Ventura 13.5.2 at this moment.

The problem still persists. Is anyone else experiencing this?

Between this issue, and many of my tests now failing after migrating my repl’s to Nix, I’m really thinking of just abandoning replit all together. It’s become very restrictive lately in the classroom, where we are dealing with more functional problems then actually learning to code.

This has also been documented in a previous thread from Jan of 2023, but then went dead.

I am having the exact same problem with my classes.

If you’re having problems with TESTS, you need to find an old repo that the tests work for, and copy the contents of .replit and replit.nix (both hidden files) into the new repl’s. Then the tests will work.

If it’s loading times… We’ll see if I have my students update their repl’s if that remedy’s the same problem.


I am having a huge problem with this, particularly this last month since the start of the school year. Students have to wait around for 5 to 10 minutes sometimes for their repls to load. Sometimes the instructions never load. It is quickly becoming unusable as a class room tool as students spend most of their time waiting for assignments to load as opposed to actually doing them. It derails my class daily.

I have worked with our IT team to ensure that it is nothing on our end. It is so frustrated as I have built out all my classes in replit with instructions and unit tests, which are impossible to batch export and need to be manually copied. The platform is great, I just wish the load times weren’t making it unusable. Any insight or tips anyone could offer would be great!


Our replit teams for education is working inconsistently day to day and student to student. The projects were copied from a previous team. Our 2 current classes are @CP1-Period-1-Fall-2023 and @CP1-Period-2-Fall-2023. Projects will load for some students and not others and webview will work for some and not others. Students are getting understandably frustrated.

Repl link/Link to where the bug appears:

Screenshots, links, or other helpful context:

code snippet

I am experiencing the same issue. Copied files from the spring into the new class for this fall, and lots of inconsistent loading issues.

I am also having this problem using Teams for Education. Long loading times. It was not like this at the end of the last school year (June 2023). Has the Replit Staff addressed this issue?

I have an issue today with Replits loading in education teams. The are not loading, or loading really slowly.

Also Replit saying that unit tests are only available in Python, JS etc repls. Well it is a Python repl! Where are the tests that I’d already written?!

Thanks for this. I’d written three Python assignments with unit tests no problem. Came to the fourth and final one and the unit test button is greyed out.

I go to the only older repo with those tests in and it says this:

In a separate(?) issue my team repls are also loading really slowly. I’ve got 100 students starting next week and I really want the experience to be a good one for them!

In a separate(?) issue my team repls are also loading really slowly. I’ve got 100 students starting next week and I really want the experience to be a good one for them!

I have the same number and this is week 2 for us. The slow down’s have been varying during times of the day (I have 4 class between 9 and 3 MDT) and inconsistent. Ruled out browsers, os versions, and firewall/dns issues with IT. I’m fairly confident it’s on Replit’s end.

It will typically load eventually, but I’ve seen it take 5+ minutes. I remind my kids this is the joy of technology…

If you find any workaround please let me know!

+1 at my school. Students are not able to run tests, and consequently auto-grading is not available. Also having the same issue with loading times as others in this thread. It’s put my class pretty much on hold.

1 Like

The Replit staff have implemented a fix. Let us know if you are still experiencing issues.

+1; has been sporadically so slow that it’s unusable. Have heard the same from teachers within the AP CSA support groups online. I had frustrated students today who were unable to code and had to pair with someone who had a functional program.

Welcome to Ask @aschenk! This may be a separate issue.