Packages not installing and program stopped working

I had a replit that was running fine, but I just reecently refreshed the page and now the repl won’t start up. Now when I press run for my program I get this:

Traceback (most recent call last):
  File "", line 1, in <module>
    from bot import start
  File "/home/runner/Digital-IB-Converts/", line 3, in <module>
    from replit import db
ModuleNotFoundError: No module named 'replit'

I tried deleting my package lock file, and installing the packages manually, but now they are failing when I try to install them I get this:

Replit: Package operation failed.

I tried cloning the project and even then the packages were not installing. Please help

Try going in the Shell tab and running:

poetry add replit

And if that fails:

pip install replit
1 Like

neither worked :frowning:

Here’s the response for both:

~/Digital-IB-Converts$ pip install replit
An error occurred during configuration: option use-feature: invalid choice: 'content-addressable-pool' (choose from '2020-resolver', 'fast-deps', 'in-tree-build')
~/Digital-IB-Converts$ poetry add replit
Traceback (most recent call last):
  File "/home/runner/Digital-IB-Converts/venv/bin/poetry", line 5, in <module>
    from poetry.console import main
  File "/home/runner/Digital-IB-Converts/venv/lib/python3.8/site-packages/poetry/console/", line 1, in <module>
    from .application import Application
  File "/home/runner/Digital-IB-Converts/venv/lib/python3.8/site-packages/poetry/console/", line 7, in <module>
    from .commands.about import AboutCommand
  File "/home/runner/Digital-IB-Converts/venv/lib/python3.8/site-packages/poetry/console/commands/", line 4, in <module>
    from .check import CheckCommand
  File "/home/runner/Digital-IB-Converts/venv/lib/python3.8/site-packages/poetry/console/commands/", line 2, in <module>
    from poetry.factory import Factory
  File "/home/runner/Digital-IB-Converts/venv/lib/python3.8/site-packages/poetry/", line 16, in <module>
    from import Locker
  File "/home/runner/Digital-IB-Converts/venv/lib/python3.8/site-packages/poetry/packages/", line 2, in <module>
    from .locker import Locker
  File "/home/runner/Digital-IB-Converts/venv/lib/python3.8/site-packages/poetry/packages/", line 38, in <module>
    from poetry.utils.extras import get_extra_package_names
  File "/home/runner/Digital-IB-Converts/venv/lib/python3.8/site-packages/poetry/utils/", line 7, in <module>
    from poetry.utils.helpers import canonicalize_name
  File "/home/runner/Digital-IB-Converts/venv/lib/python3.8/site-packages/poetry/utils/", line 11, in <module>
    import requests
  File "/home/runner/Digital-IB-Converts/venv/lib/python3.8/site-packages/requests/", line 43, in <module>
    import urllib3
ModuleNotFoundError: No module named 'urllib3'

Run in the Shell tab:

After fixing pip:

pip install requests urllib3

After solving the issues above, try adding replit again.

yessss you done did it! Thank you!

1 Like

although I will say the packages still aren’t showing up in my packages tab. I actually ended up just manually uploading like all 20 of the packages and their dependencies earlier today cause it was a bit time sensitive. I’ll see if the program will actually run without them in there later today. Appreciate the help though!

Poetry is usually really good at that.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.