I can not install packages, received error "Setuptools Deprecation Warning" install is deprecated

Problem description:

I can not install packages through the package tools. I am receiving an error message “Setuptools Deprecation Warning” Install is deprecated. I tried using Pip install pip install Django-crispy-forms and I get this error message, /usr/bin/env: ‘./python3’: No such file or directory.

I tried to fork the replit but I am still having the same issue.

The Pyproject.toml file states I am using the following versions below.

Django = "^3.0"
python = "^3.8"
setuptools = "^65.6.3"

Expected behavior:
I should be able to install packages through package tools or using pip install

Actual behavior:

It is not allowing me to install packages

Steps to reproduce:
Please see the screenshot below.

Bug appears at this link:

windows, chrome

Hi @yamilyrealty thanks for your post and welcome to the community.

I’ve just created a blank Python repl and used packager to install django crispy forms. It worked without any issues so if I’m missing a step to reproduce the issue reported above please provide more details.


Please feel free to fork the Repl if this resolves your issue. https://replit.com/@IanAtReplit/DjangoCrispyFormsTest

Hi Ian,

Thank you for taking the time to write to my post. I created a video through Loom so you can see what I am experiencing on my Repl. Let me know if you have any suggestions that can help me with my issue. I greatly appreciate it. Thank you in advance.


Update, I created a new Django Repl, then I moved my files. Then I went to install the Django crispy forms and it let me, then I step away from my computer and came back 30 mins later, and tried to install Django creditor, and then I received the same error message. Looks like it might be an issue with the Django template.

I then tried a python repl, and I received this message below.
~/xcellencetools$ pip install django-crispy-forms
An error occurred during configuration: option use-feature: invalid choice: ‘content-addressable-pool’ (choose from ‘fast-deps’, ‘truststore’, ‘no-binary-enable-wheel-cache’)
~/xcellencetools$ pip install django-ckeditor
An error occurred during configuration: option use-feature: invalid choice: ‘content-addressable-pool’ (choose from ‘fast-deps’, ‘truststore’, ‘no-binary-enable-wheel-cache’)

Hey @yamilyrealty!

I am unable to reproduce the error on your Repl. If you are still experiencing the issue, can you please copy the entire error that you get and send that to me so I can better understand the issue?

Hi Shane,

Thank you for replying to my issue. The error message is only happening in that project file. When I fork the project the problem still exists. Then I downloaded the project files to my computer and created a new project. It also happened on the new project as well. I did not give up, then I started a new project once again and passed the project files, and looks like the second time around it worked and now I was able to install packages on the new project. I appreciate all the support I received from everyone in the community.

P.S. Not sure why my reply messages are displaying like this with a scroll bar.

1 Like

It’s being read as code, if it’s surrounded by backticks (`) or indented, that may be the cause.

1 Like

run in shell:

sed -i 6d .config/pip/pip.conf

really they should have done this the default python template along with a pip install -U pip, to avoid this error from occurring after pip updates

I tried the command you provided on the project with the issue, and I am still receiving the python3: no such file or directory. I think there is something wrong with this Repl. I am not going to use this Repl anymore. I already made a new Repl and transferred my code and the pip install works on the new project. But thank you for trying to help. Have a nice weekend.


1 Like

I’m glad you have managed to get it working with a new Repl @yamilyrealty ! Hopefully the issue won’t reoccur again.

The reason pip isn’t working is because the nodeJS template doesn’t have Python installed.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.