HTML/CSS/JS Webview and New Tab Invalid Response + SSL_PROTOCOL_ERROR

Problem description:

When I create a HTML/CSS/JS REPL, the code is correctly displayed in the Webview and in a New Tab at first. However, after 5 minutes, the web view will break with the error: <guid>.picard.replit.dev sent an invalid response. and the New Tab will break with an ERR_SSL_PROTOCOL_ERROR.

This behavior breaks when I run the code connected to my ISP, Xfinity, but does not break when I am running from a Verizon mobile hotspot. I assume this is because Xfinity applies an extra cert check that Repl.it’s hosted environment is failing.

I have noticed this error is particularly bad on a few subdomains, which I assume are mappings to virtual machines or clusters responsible for hosting. Perhaps a few of the machines need their SSL cert behavior checked?

Definitely not working (breaks after 5 minutes):

  • Picard
  • Spock
  • Riker

Seem to be working (continues working indefinitely):

  • Worf

As of now, my only workaround is to fork the REPL and hope that the fork lands on one of the working subdomains. I am using Repl.it to teach a class, and I would rather not make my students repeatedly fork their projects to get them working.

Expected behavior:

Webviews and New Tab display of HTML/CSS/JS code should consistently work and not throw SSL errors.

Actual behavior:

After 5 minutes on certain hosting subdomains (esp. Picard, Spock), the web view will break with the error: <guid>.picard.replit.dev sent an invalid response. and the New Tab will break with an ERR_SSL_PROTOCOL_ERROR.

Steps to reproduce:

  1. Connect to Xfinity ISP (Doesn’t repro on Verizon mobile hotspot, haven’t tried others)
  2. Create a new HTML/CSS/JS project or fork an existing one
  3. Open the display in a new tab and take note of the subdomain (the ‘’ in '.replit.dev’ at the end of the URL bar)
  4. If the subdomain isn’t ‘picard’ or ‘spock’, keep forking and checking until it is
  5. Wait 5 minutes
  6. Refresh the pages and see if it breaks

Bug appears at this link:
https://replit.com/@botbunk/fip

Browser: Chrome Version 120.0.6099.216 (Official Build) (arm64)
OS: MacOS Sonoma 14.0
Device (Android, iOS, NA leave blank): Macbook Air M2
Desktop app version (Avatar menu->“Version”) or NA: Unable to find this.
Plan (Free, Replit Core): Free

Here is a screenshot (as a new user I can only upload 1, sorry:

Related discussions:

1 Like

More related discussions:

More screenshots:

Screenshots of the SSL certs:


We did have an incident over the weekend but it should now be resolved.

Thanks for the reply Suzy! Unfortunately, I still have the issue. I just forked the offending REPL and landed on spock, and after a few minutes the Invalid Response showed up again. You can see the newest fork here: https://replit.com/@botbunk/foobuh

Deploying in any way, and using that url instead should fix the problem.

1 Like

Forked the Repl and it works fine for me on spock. You may wish to logout and clear your browser cache. Alternatively, you can test on Chrome Incognito mode or another browser.