How to disable autocompleting code?

When I am writing code, a lower transparency recommendation appears in front of it. I have Code Intelligence disabled and it’s not Ghostwriter because I’m not subscribed or in a free trial. I’m learning to code and I find it really intrusive and disruptive to my thought process.


The autocomplete code is in line 11 and in the settings sidebar you can see I have Code Intelligence and Ghostwriter disabled.

Thanks for reading and I would really appreciate any help

1 Like

That’s odd… if that was CI, I never knew it had that good autocomplete. If that was Ghostwriter, it’s odd 'cause you didn’t turn it on… try turning on CI, turn it off, then enter kill 1 into the Shell?

I just started having this problem as well about a few minutes ago. It was not there yesterday when I was using replit but suddenly happened today, suggesting me chunks of code completely unrelated to what I want to do… For example when I type “age = int” it immediately suggested a long if/elif/else statements regarding 18 as the legal age of voting, which has nothing to do with what I am trying to write…

I turned off code intelligence, used kill 1 to reboot, then closed replit app and reopened it… Nothing works. I do not have ghostwriter and I’m not in a trial for it. I’m pulling my hair out not sure what to do to get rid of it.

Up till yesterday I was using code intelligence fine and it is helpful to detect syntax errors, and didn’t attempt any of these ridiculous suggestions. Not sure what is happening and hope there is a solution soon.

See the large section of code… all autocompleted


New feature for free users, they probably have a few bugs to work out.

1 Like

@NuclearPasta0 I don’t think it includes autocomplete for code?

I dunno, the post mentions “basic features”, and they show images of it but they are free users.

Thank you! That makes total sense and I was wondering if this is a bug with a new feature as it wasn’t there just a few hours ago… Just hope they would solve it ASAP as it is suggesting all sorts of chunks of code (some amazingly accurate based on past projects but totally irrelevant to what I am intending to do right now…) — it is actually quite comical if I am not stressed out :sweat_smile::sweat_smile::sweat_smile:

1 Like

It’s not in the settings it’s at the bottom of the file you’re writing.

If you go to your tools and AI it’ll open up this :

where you can disable autocomplete.


Thank you for taking your time to help me… I tried to click on the AI control and this is what I see:

And there is not an AI tab among the choices I have in the tools. Am I doing something wrong?

This is what I see in my tools tab:

You’re welcome. I was having the same issue too.

There’s now an “AI code completion” toggle option under settings.

Toggling this off should solve it.

Thank you for taking your time to help me. I did see the option you showed in my settings tab. However it was toggled off when the auto completion kept appearing. I toggled it on then off again and it didn’t change anything, which is why I suspected there might be a new bug introduced when they upgraded the system.

1 Like

The problem seemed solved just now under the following circumstances:

I was trying to run my code and I had a typo in one of my variable names and encountered a naming error, and the AI icon appeared on the side of my console tab where the red error message was showing, asking if I wanted AI assistance for debugging. When I clicked “yes” the AI tab with the options shown in vvithershins’ previous reply appeared and I was able to toggle the autocompletion off from there and finally stop it.

However after that I tried to click the AI button at the bottom left corner of my coding main tab again just to check, I again see only the “upgrade to ghostwriter” and not the options to toggle anything off and on, which is fine for me since I really don’t want to use that feature at least for now…

Thanks for everyone who tried to help me and took their time to reply. I am posting how it was resolved for me in case someone else is also having this problem and want to try it to see if this works for them too.

1 Like

The issue seems to be happening for mobile specifically. On the desktop version it can be easily disabled.

  1. Open the replit you want to work on in your (mobile) browser.
  2. Open your browser settings and look for “Desktop site” and check the box.
    (It will now load the desktop browser version of replit in your mobile browser)
  3. Now you will be able to see the AI autocomplete toggle at the bottom of your replit workspace.
    the button is kind of small and can be finicky so try zooming in and out if it doesn’t open the first time you tap it.

if you now switch back to the mobile version ( step 2 but unchecking the box) you should no longer have the AI suggested autocompletions though you won’t be able to turn it back on (if you want) unless you switch back to the desktop version (step 2 again)

I tried it in both mobile Chrome and mobile Firefox.