Deployment bundling returns error "Failed to get Nix directories"

Yes, once again, my OS Building Simulator is not working. I just got this error as to the point where the Bundle stage returns the error “Failed to get Nix directories.” The images below should explain:

What exactly happened here? Could anybody explain?

Hello @UtkMcpe78!

What type of deployment are you using?
It would also help if you could send the link to your repl:


Seeing you have hidden the contents of the hidden array are you sure you know of it’s purpose?


Hey Fairies -I’m having the same issue. The link to my repl is below, would be great if you could let me know what I’m missing. (I’m VERY new to this)

Welcome to Ask @MalcolmWyllie!

What do you want the server to display?

I have the same issue. You can replicate it by deploying a new React Javascript. Empty project. Just make a new one, and deploy it. If you click run, it works, if you deploy it, you get the same fatal error: fatal: Failed to get Nix directories.

Same issue. Just started yesterday. Please sort it out.

Thanks for the welcome!

I’m trying to make a Farcaster Frame that displays different images on button clicks, sending POSTs back to my server.

It’s built using Fc:frame metatags.

It looks like this issue starting poping up for many yesterday. I’m wondering if it’s a Replit issue?

It should be a replit issue. You can replicate the same issue with a blank project. On my React Apps, I get the same issues, and I did not touch the code at all.

Yep you’re right, just tried

Is it a Static deployment?
I’m trying to reproduce the issue.

I’m not getting such an error, I’m getting this:

Reserved vm here - it’s a discord bot for me

Not surprised that there’s another error, I’ll go through that shortly.

If you create a new Next.js Repl and immediately try to deploy you should get the same error. That’s the case for myself and a few others

I didn’t test the static one. I selected the Autoscale deployment. If you select a blank React App (javascript), with these config:

Build command: npm run build
Run command: serve -s src -l 3000

You will get the same error: “failed to get Nix directories”

Okay, I’ll try that.

Yeah, because serve doesn’t exist it’s trying to find a package

It doesn’t fail to build. If you click on run, it will run correctly. The issues happens on the third step (bundle)

Bundle stage here too. Same error. And all mine is run node index.js

Yeah, I can confirm the issue does happen.