Connection reset

Starting recently, I have a student who most of the time, cannot open their Repl in either Webview or a new tab, with the Repl’s workspace open. It says “The connection was reset”. We’ve tried on multiple laptops, on multiple Replit accounts, all the same problem. We did an internet speed test, was 38mbps.

However, I’m able to open the same Repls on my computer with no problems. My internet speed is less than my student’s (32mbps). What could be the problem?

One more thing, if my student creates enough projects, eventually one will work.


The same thing happens to me as well

Seems like some * URLs get blocked, but not others (depending on the Star Trek character that comes before in the URL). Many of my students are on school laptops with no control over the settings. This was not an issue in 2023 with URLs. Any solutions?

1 Like

I guess you’d have to unblock * in the school’s firewall. As far as I know Firewalled Replit still works. It has documentation on how to unblock it specifically.

I couldn’t find any documentation but I think if you want to use normal you’ll need to let,, and (ReplDB) through the firewall.


well that firewalled replit wouldn’t be very fun i can tell you that lol

1 Like

It’s not meant to be fun; it’s meant to be safe. It has all community features disabled, making it ideal for use in schools. This isn’t as important now that you can’t run other people’s repls without forking them but still is advantageous because if I understand correctly you won’t be able to view any public repls (thus you can’t fork them) unless they’re shared directly with you.


Ah here’s the list I was looking for:
It’s a bit outdated. I’d say go with what I previously said as well as

1 Like

that again would be terrible all of those restrictions on Replit but that’s my opinion others might like it like that who knows everyone’s different in there own way and i’m fine with that its just what makes the world go round!

1 Like

Seems like it was an issue with which DNS servers are used to look up certificates. The fix (for Chrome) is to go to:

Settings > Privacy and security > Security > Use secure DNS > With Custom

Then choose Cloudflare (


if you’re using MS Edge, try to add in the setting.


Here’s an alternate solution that allows the "official"solution to work if Chrome or Edge are “managed”: use Firefox.

I’m in a school and the problem is that both Edge and Chrome are managed browsers which means it’s impossible to change settings like the DNS.

Luckily it’s still possible to install Firefox into a student’s account without admin access so this is one way to get around those restrictions and get a working DNS.

1 Like

Tried this also, but still doesn’t work. What settings did you use in Firefox?

1 Like

It ended up being the “Increased Protection” option. Cloudflare was the default. It could have been coincidence that it worked for that student, but this student had been having no end of troubles using the managed Chrome browser and the moment we switched to Increased Protection in FireFox and reloaded the Repl the graphical output from pygame zero worked.

Before changing the “Enable secure DNS using” option to “Increased Protection” the repl didn’t work on FireFox either.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.