Ways to get SNI in NeonDB?

How do I get node postgres (postgres - npm) to support neon database?
Rn it gives me:

Unhandled Rejection at: Promise Promise {
  <rejected> Error: Endpoint ID is not specified. Either please upgrade the postgres client library (libpq) for SNI support or pass the endpoint ID (first part of the domain name) as a parameter: '?options=endpoint%3D<endpoint-id>'. See more at https://neon.tech/sni

I tried putting the endpoint thing in the password (with : and $) and in the query parameter to no avail. Only the cli can work ,but that is out of the scope for this project.

How else can I get the endpoint-id in postgres, or enable SNI?


Kinda hard to do this without control of the environment…

Are you using a connection string or an object to connect?

1 Like

I am using a connection string, but I’ve given up on neon db, switching to supabase!