“Upload file” button not working

When I click the “upload file” button, nothing happens. The same thing goes for the “upload folder” button. I’ve been able to upload all kinds of files for other programs in the past, but today I’m not. I’m using safari on an iPad pro. (C++ to program). I tried using different browsers, but it still doesn’t work. I also thought it might be a connection issue, but it’s not. I even tried restarting my device. I don’t know how else to fix it.


Welcome to the community, @SofiaZevallos!!! If you just click on a file or click on the folder section then click upload file, it should work. :slight_smile:

If you are still experiencing this issue, please let me know! Also, if you could provide a screenshot, it would be really helpful!

I’m having the exact same problem!! On a Macbook Pro 2020, I’ve tried with Safari and Google Chrome - both do not work.

1 Like

Have you got yours working? Mine still isn’t working today :frowning:

Hi @AoifeSully ,

Are you able to drag files into the files section of your Repl? This is an alternative to using the upload button.

1 Like

My students are having the same problem as well as I am. It was intermittent since the start of the semester but the last few days they have had no luck with the upload button. Dragging, however, does work.

1 Like

Same! I just raised a question too , my students are unable to continue their projects because of this particular issue, please help!

Hey! Update:
Dragging file from source folder outside replit and dropping it in the replit file view section works! It adds the required image . Thank you for the hints!
However, the add file option must be fixed :frowning:

We’re looking into the issue now. A current workaround would be to drag and drop files into the sidebar.

1 Like