Typo in Python 3.11 template

From @replit/Python-311/pyproject.toml:

python = ">=3.10.0,<3.11"

Shouldn’t this be python = ">=3.11.0,<3.12"?


Could a staff or whoever able to edit that Repl please fix this? It’s just a simple typo, not a whole new feature I’m asking for here.


I just checked for you and it looks someone has updated it already?

1 Like


I checked and it still says:

python = ">=3.10.0,<3.11"

I’m guessing that someone forgot to click Update after fixing the dependencies (it is a template).

1 Like


Doesn’t seem to be a caching problem. I forked the template and was still greeted with >=3.10.0,<3.11.

Replit staff just forgot to Update their template after editing it.


Can we try to clear our cache and reload this: https://replit.com/@replit/Python-311 ? I have tried the same on multiple accounts and still seeing the updated values. If that doesn’t work, I’ll reach out internally to our team. Thanks!

I tried reloading without cache, and also looked from a separate device on an “incognito” safari browser (signed out), and I still see the same thing.

I forked it yet again and I still see 3.10.

Tried from a device that’s never opened that template earlier, and it still sees the old code. Perhaps the template needs to be re-published/have the update published?

As of today, November 12 (UTC), the template is no longer accessible. Is there something wrong?