The deployment failed to initialize due to a configuration or code error in React Repl

Hello there,

This is becoming frustrating. My apps cannot deploy. I’m working on React apps, and they are not functioning properly.

I’m encountering this error:

forwarding local port 5173 to external port 1104
starting up user application
sh: 1: serve: not found
2024-03-08T23:29:19Z error: The deployment failed to initialize due to a configuration or code error. Check the logs tab for more information. For additional support, please post on and a staff member will take a look.

You can replicate the error by simply creating a new React app and deploying it as autoscale. I encountered the same error with one of my clients and a new app. Is anyone else experiencing these issues?


No one yet? I mean, is failing to promote an empty project. The project is the one suggested by replit. I’m unable to promote any projects using react and vue. I did not change any configuration from last time I was able to promote.

1 Like

Your post might not have been seen by staff because it was not in the Support category. I’ve moved this to Bug Reports now, so hopefully this can get some attention.

Can you send a screenshot of the configuration of the deployment?

1 Like

Hi @CryptoRevolutio There are a lot of React templates so I’m not sure which one we’re discussing.

The standard Replit “React JavaScript” template is meant to be deployed Static as the default (as shown in the .replit configuration file and also it should be recommended when you go to the deployment tab), which worked fine when I tested it.