The Backwoods Help

I was trying to run The Backwoods (a game by @Reykr ), but instead of running when I opened it, it showed the code. I tried forking it, but it said there was an error with “Secrets”??? What do I do???
Ocean Waves (previous username Unicorn Rainbow)

Replit Profile:

This also happens with almost every other project I open. When I try to fork them to run them, it says:
Configure missing Secret values

This Repl contains Secrets that might be required. Add values to ensure the code runs as expected.

Does this have anything to do with why it isn’t running? How do I fix it?
Ocean Waves (previously Unicorn Rainbow)

Look in your repl, if it tries to get other Secrets. Could you send the link to your repl?

The Backwoods:
My forked repl:
Let me know if the forked link doesn’t work.

The repl may be set so that it cannot be forked (look at the credits to IroncladDev), and there are other errors with the repl as well. My guess is that it was not meant to be forked, but Reykr may have not foreseen the Run button being removed.

1 Like

I believe that such anti-forking measures can be easily circumvented. I will report back soon with a modified version which does not have anti-fork protection.

UPDATE: The problem was that the repl used a defunct graphql endpoint. I have replaced all code pertaining to the api with a filler:

1 Like

Ah, this error must be due to the new updates. I think a bunch of stuff in the game relied on external things, though it’s been a long time since I went through the mess of code there. Since Replit has changed a lot of things (no run buttons, hosting, etc.), there’s probably a lot of lost functionality.

The anti-fork code never actually worked in the first place, it was definitely forkable and the anti-fork stuff was commented out. @python660’s version appears to work. As far as I know, there’s no extra secrets that need to be configured despite the warning messages.


I was wondering why you weren’t banned for GraphQL :thinking:
But anyways…