Students Can't Log in using Google

Over the past week, I’ve had a handful of students who haven’t been able to log in using Google. When they try logging in, they get a message saying “something unexpected happened, please try again”. Continued attempts to log in give the same result.

I saw a post about a similar issue that suggested they change their password and log in manually. When trying that, they got a message telling them to sign in with Google.

My students haven’t been able to log in in almost a week and I’m considering asking these students to work on the assignments offline if the login issues persist. If anyone has suggestions/solutions to this, I’d greatly appreciate the help!


Potentially unhelpful but have these students attempted to login on a different computer? Perhaps in an Incognito window?

I am having a similar issue with my students. Some are able to login however, it seems to be signing them up with a brand new account with their usernames as a string of numbers. These are students who previously signed in with google and had work from last year. In my ‘team’ their old accounts are present as well as their new ones. Any ideas…?

I have the same problem. My students get a message along the lines of
User already exist with [email address] please log in using your password or go to [forgot password link]

I really don’t want to direct them to the forgot password link because that ends up with them creating an account that isn’t linked to their Google account (and I want it linked to Google for administrative reasons).

1 Like

And I have tried getting them to log in on a different computer. It doesn’t seem to help.

I have 2 students who had this same error show. Also, one of my classes isn’t showing as my team member, however their screen shows they are on the team/has access to it. They all signed up using Google.

I am seeing these same messages with some of my students today. It was 2 today and I pray it is not more tomorrow…

Are students still seeing this issue? We temporarily reverted an authentication change Monday-Tuesday, which was supposed to seamless but sounds like it was creating issues for newer OAuth accounts.

You can submit a support ticket (not an ask forum post) with the accounts to remove if there are a large number.

1 Like

I am still having this issue with a student. The student is not a recent account (they used replit all last year without issue on the same account)