Strange behaviour of mobile app

Problem description

Hello. My mobile app started to act strange.

I use the defaultly generated .replit file and the editor worked fine until now (see “Actual behaviour” for description)

Expected behavior

normal work

Actual behavior

Suddenly, replit started to complain that the run is not configured and I should do that in the .replit file, even if it’s the same one that was automatically generated with the project and with worked before wuthout any problems

Steps to reproduce

not sure… I’m not knot from with side should I get to it :thinking:




Android 13

Device if mobile

Oppo Reno5 5G



@mcgiwer Could you post the error code/error message of “not properly configured replit”?

There are similar topics around now and this way we can find out if they are duplicates.

Hello @mcgiwer!

Could you please copy-paste the contents of your .replit file here?

Hi @mcgiwer !
Try entering kill 1 in the Shell, or exiting the repl and re-entering it.
If this issue still persists, try entering this line above the entrypoint line in the .replit file:

run = "python3"

Hope this helps!

1 Like

unfortunatelly, for some reason the mobile app prevents selecting and coping of the console content.

The message says that the run is not configured and I should put:

run = "python3"

into the .replit file, even if similiar entry already exist in it, but as:

run = ["python3", ""]

like it was orginally genetated while project creation.

Unfornutatelly, I’m unable to attach an screenshoot because I get every time a “An error ocurred”, even if the file is small

Try the first one like I suggested. If it doesn’t work, split it into a list and use that instead.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.