Showing os error when trying to install

When I am trying to install in shell showing OSerror no 13 so how I can fix?
Repl link:

code snippet

Hi @TWO-PARTYPARTY , welcome back!
Try running poetry add in the Shell, instead of pip install.
Hope this helps!

1 Like

Could you add the link to your repl?
Also, try adding a pyproject.toml file if you don’t have one, and enter this:

name = "python-template"
version = "0.1.0"
description = ""
authors = ["Your Name <>"]

python = ">=3.10.0,<3.11"

useLibraryCodeForTypes = true
exclude = [".cache"]

select = ['E', 'W', 'F', 'I', 'B', 'C4', 'ARG', 'SIM']
ignore = ['W291', 'W292', 'W293']

requires = ["poetry-core>=1.0.0"]
build-backend = "poetry.core.masonry.api"

Then, run the poetry command again.

Try removing the "" = "^2.3.2" line in your pyproject.toml, then run poetry add in the Shell again.

Deleted the “” = “^2.3.2” from project.toml but after entering poetry add is automatically getting added in pyproject.toml

I see. Try deleting the requirements.txt file, then run poetry add flask requests in the Shell.
Then add this below your existing code in your .replit file:

modules = ["python-3.10:v18-20230807-322e88b"]

hidden = [".pythonlibs"]

channel = "stable-23_05"

language = "python3"

run = ["python3", ""]
deploymentTarget = "cloudrun"

Hope this helps!

1 Like

There should also be an entrypoint variable, so that the repl can be run in the workspace.

I’d assume the repl already had one:


Yes, but it only had run and entrypoint lines.

Usually the configuration is completely replaced rather than extended.
I was skimming it so I missed that.

(Also, the venv folder should be deleted because it would now be redundant.)

Another important thing is that the python version specified in the pyproject.toml file is "3.9.6", and it should be changed to ">=3.9,<4.0" to prevent poetry errors.

1 Like

I forgot to tell you that about 9-10 days ago the repl is working properly without any error or something but 4 days ago I tried to use this again but I saw this on screen and after that the repl not working

Did my post or NuclearPasta0’s post above help?
For the upgrade of the environment, was this repl created really long ago?

The OP is using some old template that has venv configuration and it looks like it wasn’t even originally a python template repl.
Did the upgrade finish successfully?

After editing the .replit file I tryed to run the code but showing

But after your solution packages started showing and then I tryed to edit . replit again and it worked but then showing no module named `discord’ or when I am trying to INSTALL or delete showing this

By running curl -s | bash -s in the Shell (command made by @Firepup650 ), then installing the packages, it worked.
Here’s the repl I made:
You can fork the repl and use it, but remember to add the Secret for your bot in the repl.
Hope this solves your problem!

1 Like

Thx code fixed but don’t know what happened to my code bot not replying to my text files -_ btw thx

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.