Running issue for after a while

Question: whenever i run my html css js repl it doesnt show anything, it was working for about 4 months before, but then i havent opened it and now it wont run

Repl link/Link to where the bug appears:

Please store the API key in Secrets, not in the JS file.


That isn’t possible here, they’re in a


Yes it aint possible, what do i do then?

Maybe use a Node.js repl instead, but use Express? The the Secret can be stored?

cant, will take a long time and might face error bc i aint that good at express

You should hide all your keys in the secret environment tool.

FS updated its functionality. You’ll need to update your working knowledge of fs or switch to express. In my opinion, express is better.

You can ask ghostwriter to place the express code or reference the documentation, it’s not too difficult.

They aren’t using FS?

AI heavily hallucinates.

As a third note, they’re currently using a server-less setup, so they can’t do any of this atm.


Well, you won’t need to do much. Just setup the / route since the others won’t matter, then just add on the other files (since it may only have 1 page, other routes aren’t needed).

1 Like

But i actually dont want to bc if finding hosts and ect… It was working before why it isnt anymore?

1 Like

so i just selected the API keys and ctrl+x and tried running didnt seem to work

Probably because the keys are vital for the program to work, so without it, it may not work properly.

but it should atleast show the stuff but bugged bc i tested it on vsc without keys evrything showed but bugged

1 Like