Replit mobile doesn’t download images or other things properly

Problem description

Im trying to port over some assets I’ve made to my mobile device. Then I’ve tried to download them using the download button, but when I tried to see where it went, it wasn’t anywhere in the files app that I could get to. I tried to download it on the website, but I haven’t been able to login to the website for a while, but I am still able to go to the REPL and download assets from its, or at least I thought I could until the website didn’t even load the files.

Expected behavior

The assets should down to either the “On my iPad” downloads folder, or the “iCloud” downloads folder. If I was using the website, it should’ve loaded and allowed me to download it to iCloud.

Actual behavior

Replit mobile doesn’t send it anywhere in files app I can go to, and the website doesn’t load any of the files.

Steps to reproduce

  • On one device, create a REPL and import some image files
  • Go to another mobile device and go to that REPL in Replit mobile, or get the link to your REPL and use safari to get there(not the editor, since I’m not able to get to the web editor currently)
  • Attempt to download from mobile or the website. Mobile won’t even download it, while the website would not load files.


Safari(only for website ver)


iPad OS

Device if mobile



Free tier

1 Like

If you now a way to get around these issues, tell me as well.

1 Like

also if you saw the assets you just a sneak peak to one of my games coming very soon, so don’t steal them or else. you can use them once the game is released tho

1 Like

On the website add .zip to the pure repl link like so:

1 Like

I tried doing that, but it lead to a 404 page. Can you correct this link if I did something wrong?

1 Like

This doesn’t work for you?
That’s certainly strange, maybe forking it will fix the issues.

@Bedrockminer if I fork the repl and do it (you have to own repl to download) it works, I’m attaching the file here.