Replit cannot reach flask server

Bug description:
My flask server which runs in a python thread cannot be reached just now.
It seems that replit is not detecting the port opened on my repl and not redirecting the traffic to it.

Expected vs Current Behavior:
The Flask server API should be able to be reached.
Replit says it couldn’t reach this repl while the code is running

Steps to reproduce:
Run a flask server

Bug appears at this link:

Screenshot(s)/Screen Recording:

Browser/OS/Device: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/ Safari/537.36

Replit Profile:

Just tested out my other repl that uses waitress to server flask.
They both seems to not working.

Same issue here.
Even the flask example doesnt work

I am also getting the same issue. It syas “Repl Unavailable”. My Repl is running on a Flask server. What is the expected time of resolution?

Switching server location to United States seemed to resolve the problem.
This issue is likely to affect servers in India only.

The issue seems to be fixed now. Atleast for me
Edit: Uh, broke again…

My Repl is now showing this. Don’t know if this is because of the SSL Certificates Issues.

Resolved: Solved it by switching the server location to North America.

Original Issue
I am facing similar issue again.

On my webpages built on Replit, it says

" This site can’t be reached unexpectedly closed the connection."

Let me know what could be the issue.

I have same issue with my server created in FastAPI.
Checkout here :

How can i switch my server ?

@HaseebMir Got to:

Click on your account ID (Top left hand side corner) → Account

Then scroll down to the part:
Your server location
Then choose: North America

Let me know if this works.

1 Like

My server is also down again. Changing server location didn’t work.

Here is another thread that I posted.

Thanks its fixed now

Welcome @HaseebMir

@seanho12345 Can you check if you are on the North America server? In fact I used your solution which worked for me.