Repl when at maximum CPU

Problem description

I have a code importing a PSD file and slicing some pictures out of it. However everytime I run the repl and it shows CPU usage of over about 95% for a second or two, I get a message, that the repl was killed

Expected behavior

running normally.

Actual behavior

killing the repl.

Steps to reproduce

open a psd file of 88.1 MB size using psd_tools. Or just fork my repl and run it:




Mac OS

Device if mobile

iOS (I didnt try it on mobile)



Please upload screenshots

Perhaps your repl was using too much RAM? If your repl runs out of memory, it would have to kill some processes to free up some memory, and in this case, it killed your program.


I thought that it would probably be doing this but I didn’t find anything about it in the internet or on replit. Thank you for your answer I have tried it on my pc and it runs smoothly so that was probably the cause.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.