Repl console text is rainbow/glitchy

Firefox 114.0.1 (64-bit)
it started happening about 2weeks/a month ago, Anybody know why it happens and how to fix it?
it was working before, is there any way to fix it via using about:config in firefox or something?

if i copy the text (like this:

) it works, ex:

Node version: v17.9.1
Make sure to run npm run format and npm audit fix if you haven't after a code change or smth
Hint: hit control+c anytime to enter REPL.
Launched Cluster 0
⏳-> [LOGINDATA] Checking data...
⌛-> [LOGINDATA] Data found, program will try to use it!
✅ -> Keep alive currently active, Code (bot) by adudu21 (AGuyThatLikesFurrys), listen on port: 4472
✅ -> File: ready.js successfully loaded
⏳ -> [LOGIN] Trying to login with provided token, if this takes longer than 5 minutes it might be cause you provided a invaild token
✅ -> File: cscfs successfully loaded
✅ -> File: help successfully loaded
☑️ -> [LOGIN] Logged into token as user MutilpleBot#6024

None of my extensions (via firefox) are causing this

Try disabling NoScript or AdGuard. I know you said it’s not the extensions, but we can still check, right?

If that has no effect, please open the console (Ctrl/CMD + Shift + I OR F12) and provide a screenshot of any messages you see there.


Does this happen if you open this Repl in chrome or another browser?

All extensions disabled:


Disabling firefox 'Enhanced Tracking Protection" does not help in this issue.

Hm. It’s another same-origin/CORS error. We had one of these a while back. Lemme dig up that post.

Edit: I cannot find it at all. I know it exists though, I’ll keep looking.

Edit 2: I finally found the post, here was their solution:

So I guess see if you can find and disable that setting?




This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.