Console doesn't show properly on linux laptop (colored rectangle mess)

Hey @BaptisteHalbot! Welcome to the community!

Could you check if the problem shows up on your other devices as well? And if the issue also appears in your other Repls?

1 Like

Thanks for the welcoming !

I have checked on another Repls, (other language) and it was the same, I already checked on my phone and it was displaying correctly but I don’t have other device I can check.

Try a refresh first, then a cache refresh (Ctrl+Refresh), and see if that fixes it.

1 Like

No that didn’t fixed it.

Hmm… then do you mind restarting your computer? If that doesn’t work, I will create a bug report and cc it to the admins if necessary

1 Like

I don’t mind, I will try it !

3 Likes

Sadly it still isn’t working…

Would sharing the browser console would be useful ?

You try, maybe there’s some error that the admins can fix.

I will try and create a bug report for you as well in the meantime

1 Like

Here is the browser console.

Hmm can you see it properly ? it seems to haven’t uploaded correcly for me :\

1 Like

It’s purple on my end. All purple.

1 Like

That’s why I thought…
I think it’s will be good now:

That is a lot of errors. I don’t even know where to start with that sadly. Seems like a lot of CORS errors though.

Referencing the MDN Docs:

The HTTP request which makes use of CORS failed because the HTTP connection failed at either the network or protocol level. The error is not directly related to CORS, but is a fundamental network error of some kind.

In many cases, it is caused by a browser plugin (e.g. an ad blocker or privacy protector) blocking the request.

Other possible causes include:

- Trying to access an https resource that has an invalid certificate will cause this error.

- Trying to access an http resource from a page with an https origin will also cause this error.

- As of Firefox 68, https pages are not permitted to access http://localhost, although this may be changed by Bug 1488740.

- The server did not respond to the actual request (even if it responded to the Preflight request). One scenario might be an HTTP service being developed that panicked without returning any data.

Try checking any browser extensions (IE: Adblockers) that might be conflicting with replit.

You can ignore the CORS errors, I just test, I’m using Ublock Origin, desactivating it removed the CORS errors but the problem is still here.

EDIT:
the console without CORS errors:

I don’t think I will be able to respond, I tried and replit show me a notification that I can’t post more before 23 hours as a “new user” (first time on forum/support, not on replit)

NEW IMPORTANT EDIT:
I suspected my browsers being at fault, my Linux distribution has a custom Firefox version (with some privacy setting and theme predefined) as the default, I tried installing the regular Firefox and it worked on it. Now that I know the browser is at fault I will try messing with the parameters to fix it, or I may switch to regular Firefox if I can’t fix it !

ISSUE FOUND:
I was able to reproduce the issue, by setting the privacy.resistFingerprinting to True in Firefox (which was by set in my version)

1 Like

Screenshot of the console with the extension disabled then please?

Good that you found the problem. You can mark whichever answer was most helpful as the solution so that we can close this thread. Thanks!

2 Likes

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.