Remove auto complete

Question:
How i can remove autocomplete?

Replit Profile: https://replit.com/@vitaliykostiuk

Hey @vitaliykostiuk welcome to the community!

You can turn off autocomplete by going into your Repl, and going to where it says Tools >, find the gear icon that says Settings and click that. Scroll down until you find AI Autocomplete click on it and it should turn it off. I hope this helps!

3 Likes

Hello. I have seen this question multiple times now and I cant seem to solve it. I use Replit in webbrowser and am relatively new.
On the top left I saw these three staggered boxes in which there was the ‘Settings’ option. This brings my to my profile, account, billing information etc. No matter where I seem to look, I can’t find anything related to AI.

Now if i go to one of my projects, there is this button ‘Tools’ but it does not bring me to any type of ‘Settings’ option. Below it there are some icons, one of which is AI (among Deployments, AUthenticatoin, Chat, Console, Database etc.). If i click it, it opens up a chat AI with the prompt

Replit AI
Use Replit AI to set up new…

But nowhere any option for ‘AI autocomplete’ or any way to turn it off.

I hope this slightly more detailled description might help you help me,
I thank you for your help so far!

Greetings.

You can create a new tab in the workspace (the + button), then type User Settings. You should find the AI autocomplete toggle in there.

3 Likes

thank you this solved it. :slightly_smiling_face:

i deactivated suggestions and it is still giving me suggestions. im trying to learn how to code but i cant think of the logic myself that it already gives me the complete code already made.

im on ios, could this be why?

Oh, you might mean Code Intelligence:


You can turn this off in the User Settings too. Scroll down and turn off the toggle switch “Code Intelligence”.

2 Likes

in main.py tab check the bottm-left corner and uncheck the ai autocomplete