PyQt5 repl no longer working

Hey, I have this repl that uses PyQt5, and it used to work just fine about a year ago, but now it simply won’t print the GUI elements.

This is the repl:

This one is a pygame repl, but I’ve also tried it in a python one, with the same result.

There’s no runtime error reported. It just won’t show the elements inside the GUI window. The window is there, but the controls and painted stuff are missing.
Well, I get this message, but I’m not sure if it’s related to the problem:
QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to ‘/tmp/runtime-runner’

It works fine on windows and ubuntu. Here’s the Github link: GitHub - kuashio/cat-trap: An intelligent that plays the Cat Trap game using the Minimax algorithm, with Alpha-Beta pruning and Iterative Deepening. This is the project showcased in the LinkedIn Learning course titled AI Algorithms for Gaming.

Can you help?

Hi @kuashio! I’ll take a look at this and see what I can find!

Thank you. I’ll sit tight.


Hi Kuashio,

If I recall correctly, PyQt5 has never rendered properly on Replit.

PyQt5 using QtQuick (Creating PyQt5 applications with QtQuick/QML) works perfectly though.

I am investigating why PyQt5 is misbehaving, but I suspect it is because Qt itself relies on OpenGL to render the window panes. Because our virtual machines do not have GPUs this is not possible.

I will continue investigating and let you know what I find!


Oh, I’m pretty sure it used to render. I was super excited to have my cat trap game run with a GUI.
I may have a screenshot somewhere.