Output window not showing up nor can I see my program when I run it

I could not see my python output, then I did kill one and output window is gone and I cannot get it back. my firewall is not blocking anything I have cleared my cache, I have done every suggestion I have read any help would be appreciated.

Is this about your newest repl AustereShorttermIntranet?

Or is it about one of your older ones?

If it is about your newest repl,
It sounds like you are clicking run but getting no output window?

You should be able to open output with the tools.

Or you can click the + to open a new tab in any of your panes.
Where it’ll again show you a list of your tools, and you can select output

If this is about one of your older repls
Do you know about editing the .replit config file?

I see that your main.py is just

from turtle import *


But you have other files with more

But the entrypoint in your .replit config file is still set to main.py which will show no output.

It sounds like you might have created a new file with a different name other than main.py , tried to run that new file, but got nothing because it was still running main.py?

If this is the case you can simply change main.py in entrypoint = "main.py" to the name of the file you want to run when you click the run button.

Then when you click run it should automatically open the output window

Docs page for “Configuring a Repl”

If neither of these help I’m sorry for misunderstanding.


it is the same on every one, output is not shown in the tools list regardless of which one I open. If I open my original one then output window is there but will not connect, no matter what I try.

Not sure why it will not connect. On another repl I pasted into my main.py and output showed this time. Not sure why I cannot connect on my original one

I just forked your repl FrostyCompetentMosaic and it doesn’t have the output in tools.

I then made it appear by changing the entrypoint in the .replit config file.

You still have the entrypoint set to main.py

Click the 3 dots button next to files.

Then from the dropdown menu that appears select show hidden files.

Now you will see the .replit config file

Open it,
The first line will say entrypoint = "main.py"
You need to change main.py to the name of the file which you want to run.

In this case it looks like you want to run circleimbedclr.py
so you change it to entrypoint = "circleimbedclr.py"


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.