No search results for "open repl in firewalled mode" - why?

I’m told by that I cannot open my repl in firewalled mode unless I ask the original author (me) to open my regular repl in firewalled mode. So, I do an internet search on the phrase “open repl in firewalled mode” and … nothing.

So, my question remains: how on Earth do I “open repl in firewalled mode”?

Repl link/Link to where the bug appears:

Screenshots, links, or other helpful context:

code snippet

This message means that someone (probably you) recently opened up the repl in normal, and then a short while later you tried to open the same repl in (and it gives you that message), or you are still in the repl from
Close the tab and either wait a while to be able to use on that repl, or do one of the following workarounds:

  • Close the tab, then open your repls page, click the Status tab on that page, and Stop the repl that you are trying to get into. Wait for a minute and open it in firewalled. (might not work all the time.)
  • On the editor tab, open the Shell and type kill 1, then close the tab really fast. Wait for a bit and open it in firewalled.

I waited a day, powered off my laptop and tried again, and this time, I was able to open the REPL and try to run it (despite the “we had a problem” display in the Output screen).

Anything like System.out.format() (i.e., write to the console) worked.

However, anything like a call to the following, fails to display consistently (mostly not, occasionally yes, but even then only in regular mode and has never worked in firewalled mode). Sorry but I don’t know how to keep the code from collapsing so badly to the left when I copy/paste but if you want to see the code on GitHub, navigate to Java JOptionPaneExample that does not work in replit but works fine in three other IDE’s:

     /** Display a question with multiple choices and return the single choice made by the user.
     * @param question - The question to ask the user.
     * @param choices - An array of strings representing the choices available.
     * @return - The single choice chosen by the user.
    public static String getSingleChoice(String question, String[] choices)
        JList<String> selections = new JList<String>(choices);
        JOptionPane.showMessageDialog(null, selections, question, JOptionPane.QUESTION_MESSAGE);
        return choices[selections.getSelectedIndex()];

Are you talking about the Output editor tab not working?
It may say “There was an error connecting to server” for a few reasons:

  1. It just does it randomly, especially when the repl disconnects. Clicking Try again or refreshing while running the program will fix it if this is the case.
  2. More likely, the domain for the output is being blocked by the network. In fact, the output got a new domain around Jan 1, and since it is new, it is probably being blocked more. It changed from ending to to ending in or something.