Nix Migration suddenly wont import from a library

Problem description:
Please be kind, I’m a novice.
Working through student tasks on a repl owned by NCCE. Version downloaded two weeks ago works fine, tried to fork a new copy today and since the migration to Nix (?) it shows an error message import pyowm
ModuleNotFoundError: No module named ‘pyowm’
Not sure how to fix this. The two programs shown side by side are identical, the only difference is the new file migrates to Nix when forked.

Expected behavior:
Program prompts user for a location. When running successfully the program should import information from the Open Weather App (so long as a valid API key is used) to provide local weather data for any location in the world.

Actual behavior:
Doesn’t even show initial prompt, just brings up error message as described above.

Steps to reproduce:

Bug appears at this link:


It’s possible that the new environment has different package versions compared to the original version.

Also try several ways to import it, like pip, or through the package lists on the left side of that package tool bar.

I’ve tried both of those, and neither of them seems to work. Using replit’s packager tool, when I press install, it doesn’t install, and when I use pip, it gives an error.

Another nix breaking the venv error, I’ll graph the required files to repair pip out of one of my Repls.