My code starts from line 2 instead of line 1

How do i fix my code to start from line 1 instead of line 2. Im coding in python and for the last week i havent had any issues then today i realised that my code started from line 2 instead of 1. i tried everything from looking into the settings but i didnt find anything. Please help.

Repl link/Link to where the bug appears:

Screenshots, links, or other helpful context:

code snippet

Hey, @Dimo01 welcome to the forums!

Can you please provide a link to the repl? This way it is easier for staff and members of the community to help you!

Also see this guide on how to share your code:

Hi @Dimo01 , welcome to the forums!
Can you try pressing CTRL+SHIFT+R to refresh the page and cache?
Or, try entering kill 1 in the Shell.
Hope this helps!


nope didnt work. I tried both methods. I downloaded replit on my phone to see if the issue still exists and it exists on my phone as well so i dont know what must have happened. It was fine before for an entire week.

this issue has been frustrating me the entire day and ive been searching everything i can to try and resolve it but i havent found anything and i have no idea what could cause this.

Seems like a UI bug. It doesn’t seem to affect programming or the file contents.


It’s not just them, I’ve been having the same issue since yesterday
Not a huge problem but it’s annoying to look at lol


Just looked and I see it too must be a bug. I have moved this over to Bug Reports

1 Like

It appears to have also affected the go to line: feature too, if you go to line 1 it takes you to line 2, if you go to line 2 , it takes you to line 3.

or maybe the lines are technically still correct but just the numbers are wrong?

1 Like

when i use the feature go to line and i press go to line 1 it sends me to the first line avalible and thats 2 when it should be 1.

thank u for letting me know its a bug i was worried it might be smth that i did and i cant fix it.

what do u think i should for now? should i leave it until its patched or smth.

bbithershins do u have the same issue?

You cant do anything until its patched

1 Like

do patches take a while to come out or do u think it will be patched quickly

It depends on the issue. Because this doesn’t break the platform you will most likely need to wait until Monday for a staff member to get to this.

thats cool thank you very much for the info!

1 Like

I’ve observed that this bug only happens when you reload after the server restarts. This means that most of the time, reloading the page doesn’t work, but it does if you kill 1 just before reloading. The bug seems to happen after focusing on the code.


good observation! hopefully this get resolved soon.

1 Like

**Question:**How can i correct Line Numbering ?

replit is not showing me correct line line number

Replit Profile:

Yes, it’s just the numbers to the left of the code being labeled one more than the actual value.

yes i am also facing the same
do you have any solution to it.

1 Like