Mobile app code intelligence does not work

Why does Code Intelligence/Autocomplete function does not work in mobile app even tho it is enabled in settings?

If this problem was already solved, link would be enough. Thx


Same here, tried a fresh python repl, node repl, typescript repl, nothing has working intellisense, in the android app or in chrome for android. And I’m using “Unexpected Keyboard” which has ctrl, alt and fn keys and more. Yes I did check Settings and the Code Intelligence option is turned on.


Are you using the latest versions of the Android or iOS apps? I’ve started a new Flask template on iOS and am seeing the intellisense working without any issue. Please also make sure that’s enabled in Settings as well. Thanks!

1 Like

Quick update from me, I did a sanity check with desktop Chrome, and everything is working as expected there.

I checked again in the Android app, and it seems it’s partially working now, because I get red and yellow squiggles from code analysis, but I still can’t find a way to do code completion or view signature and docs popup, at least not using the usual Ctrl+Space shortcut. Things like Ctrl-F12 to go to definition works though, so I don’t know what’s wrong. Maybe if it was possible to rebind that action or put a dedicated button for it like there already is for copy, paste, indent and so on.

Yes it looks like i am using the latest one: 2.56.2 on android but still there is no Autocomplition or even Code check

Hm, thats strange. I was writing in C# Mono before, and it doesn’t have any code analysis, even on PC, but when i started coding in original C# its all like you said: on PC it works fine, however on Android there is no autocomplition, but there is cheking for errors.

About Mono, is it a bug or a feature?

Just speculating, but sounds like maybe the Mono repl’s nix environment doesn’t have the dependencies needed for the default C# LSP, or it’s not compatible with the Mono runtime, or maybe not configured at all? That’s possible to custom configure to some degree in the .replit file under [languages] at least, but that’s all I know.

Interesting discovery: Firefox for Android works partially! I can use ctrl-space to open autocomplete, but unfortunately the menu does not seem to have anything from the language server, and I can’t get any definition tooltip.

Funnily, it seems to work fine if I request desktop mode (in FF for Android again), but that’s unusable for many other reasons.

Screenshots attached.

Super Mikal,

Could you like us to your Repl you are testing from? We’ll test locally on Android and let the mobile team know after reproducing the problem. Thanks!

Here you go:

But I mean, it also doesn’t work anywhere else, like this freshly made python repl:

In using iPadOS Safari and Chrome, I’m also in trouble with this problem.