Libraries in Python are not installed and can not be re-installed

Problem description: can not operate Python without libraries

Expected behavior: Libraries should be pre-installed or at least possible to install

Actual behavior: e.g. matplotlib is indicated as being missing; re-installation not possible

Steps to reproduce:

Bug appears at this link:


Have you tried reinstalling the packages VIA the Shell tab?

pip install matplotlib


poetry add matplotlib

After I had the message “matplotlib” not found, I went to the button “packages” (shell tab?) searched for matplotlib, and could initiate the install process. Back in the console, it says “Installation failed”. Maybe it is only matplotlib, but I can not run most of my replits.

Screenshot 2023-05-28 15.13.06.png

Try running one of the commands I suggested in the Shell tab, as that can usually fix missing packages even when the packager fails.

Does not work (see attachment)

Since that’s a PIP bug, try:

Then run the pip install again.

I suggest you try re-installing it using the Packages in Tools.

There has been a time where I accidentally uninstalled pip and another package, my Repl broke without the required packages, and I couldn’t reinstall anything. If this is the case, then all you can do is re-fork to another Repl.

They already tried that, which is why I’m just bugfixing pip now.

1 Like

my console answer tonight; see the attachment

Try opening the Shell tab and running:

pip install poetry

has not worked (s. attachment)

That’s a repeat issue from earlier, did you forget to:

Thank you for your advice. I could install something; obviously, the library is now recognized. But, unfortunately, the output (plot) is not appearing. Furthermore, doing the shell operation with all my other files could be more straightforward.

Kind regards