Is Java Language Server Down?


is the java language server down for anyone else? I am able to run my python code just fine. I think it’s specific to the java language server? I check the replit status page and all servers are up. Do they have a server status page for the different language servers? As I tink the Java one is either down, or bugged.

The Java LSP (like all the other ones) is a per-repl process, so that issue likely can’t be reproduced by anyone else. Could you try kill 1 in the Shell?


I ran the command. Nothing happend. Still can’t compile code and the Java language server is constantly loading. Only have issues with Java. I tried python and it loaded just fine and compiled just fine.

Here is the error message I get: “Limited language support because the language server is not available.”

That would be a separate issue from this:

That can be fixed by editing the .replit file. It’s not an error, it just means that you won’t get code intelligence on .java files.


Oh thanks for clarifying. I guess it is seperate issues. The server is back online now. But compiling still doesn’t work. I’m running simple sorting algorithims for a class. Usually it only takes a few seconds to compile and run the code. I’m sitting here and it’s been probably 10 minutes and still my program has not compiled.

Yea I think something is wonky with the java compiler. Just trying to println a simple string and nothing shows. Not sure what is up with the java compiler.

Btw it shows cpu and ram at limit with nothing running. Just with the editor open both are at limit.

Cpu shows 0% User and 100% system
Ran shows active 632mb

Tried to run a simple System.out.printlin() string an no compiling. Are the instances shared and so all java files on the site compile on the same server?

I guess I’ll just setup my own instance.

They’re not, like the LSP that’s per-repl.


Thank you for the insight. I guess it might be due to the limitations of the free version. Can’t run algorithims.

You should be able to compile a standard java program, does the issue persist into a new Repl?

1 Like

Ok I finally figured it out. I had to clear my web browser cookies and data. I guess maybe the cookies saved some corrupt data or something. After I cleared it. It is now working as intended. Apologies thanks for the help. Also thanks for the other information.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.