How do you keep hidden files hidden?

I am re-writing a Replit course shell for Java for a high school course which was started by Brendon McCart in your Curriculum Hub.

I find it useful when I want to create a similar lesson to the last one, to use Copy into the same course team and unit. When this happens, I have a problem with the formerly “hidden” files becoming un-hidden. I can reset this in the menu, but the next time I open the lesson it forgets and un-hides them again; and it un-hides them for the students as well.

Example click here.

If this is a bug, it is an annoying one. If it is a feature, how do you turn it off?

Paul

Hey @MrKingICS welcome to the forums!

You are able to edit the .replit file to hide any file you want. Also the page you liked brings me to a 404 error. If the repl is part of a team for EDU we wont be able to access it.

Any file I want? How about the .replit file itself? That, and replit.nix?

Those should be hidden by default and I don’t think it can be changed. If its being shown that’s a bug.

This is the problem. I can “hide hidden files” in the menu, but it is forgotten about by the next time the page loads. This seems to affect lessons I have copied under teams for edu.

Im assuming that that is in the file explorer. If so I will need to investigate.

I posted a bug report

1 Like

It’s a bug that’s been there for a while. I submitted a bug report some time ago.

Didn’t you get any reply by Replit Staff?

No. I submitted it through the old Feedback option.