How can I enable sound in my Repl?

Hi all,

I use a screen reader to use the internet, and I just made a working sound Repl. Or at least, it runs with no errors and I just have the Pygame intro in the terminal.

How does one enable sound in Repl’s? I asked Ghostwriter about it, and it said to enter:
aoss paplay /usr/share/sounds/alsa/Front_Center.wav
in the shell/terminal to test sound, after which it will be enabled. I suspect that was made up.

Might there be a keyboard shortcut for it? I don’t see any accessible button which might give me a hint.


Hey @Orinks! Welcome to the community!

I am not too certain about this issue, since I am not familiar with how screen readers work.

But I think this may be something with your screen reader rather than your Repl. Try to see if there are any settings that allow for any incoming sound to play from (it’s on by default)



Thanks for the help. Right now, my game appears to run but sounds aren’t being loaded into the pygame mixer correctly, despite the code as far as I’m aware being correct. All I get in the terminal now is the pygame welcome message. But I created a sounds directory with wave files and made the path ‘sounds/sound1.wav’ as an example.

Here’s the link to the Repl. I used Ghostwriter to help with most of it and I understand what the code is doing, and I even fixed the dictionary to load sounds via the pygame mixer, since initially I wasn’t loading the mixer at all which would explain why sounds weren’t playing.

Once I can troubleshoot this the next thing to add is screen reader support which should be a learning process, but Ghostwriter and, failing that, GPT-4, is helping.


At the bottom right corner of your screen, there is an option to turn on sound, click on it and it should be playing the sounds.


Is there a keyboard shortcut for that? Or a button label so my screen reader can see that button/icon?

I am not too sure about that; but I don’t think there is any keyboard shortcut that allows it to toggle the audio.

You could, however, create a custom keyboard shortcut that allows you to toggle the audio yourself.

Welcome to the community, @Orinks! The button is in the bottom right like @savardo mentioned. See the image below:

How can I make a keyboard shortcut for it myself? Isn’t the button part of the Replit interface?
Thanks for all the help though.