Help i need the help

a, b = input().split()
import math
try:
print((math.sqrt(int(aa)+int(bb)))
Time limit: 0.2 Memory limit: 32M

Description:

Use the Pythagorean theorem to calculate the hypotenuse of a right triangle. Given the lengths of the two right-angled sides (legs), calculate the length of the hypotenuse. All lengths are integers.

Input:

Two positive integers, not exceeding 1000, represent the length of the two legs of a right triangle.

Output:

Output the integer length of the hypotenuse.

Sample input:

3 4
Sample output:

5
Constraint:

a,b<=1000
Hint:

Pythagorean Theorem: $a2 + b2 = c2$ (a and b are lengths of the right-angle sides, c is the length of the hypotenuse.

I’m sorry this seems like a problem set by:

  1. a school
  2. a coding competition

until you further clarify, we cannot help you as it may constitute cheating.

4 Likes

Was going to say the same!

@Winstenna We are not able to help you if this is a problem provided by a school or alike service. I suggest asking your teacher or whomever provided this problem for help.

4 Likes

No, this is a friend challenge. Stop trying to think that this is a problem set by a school. Its not funny. Please stop.

It’s not supposed to be funny, we are not “trying to think” so either. The format of this question seems like a question made by a school or alike.

5 Likes

So could you answer the question?

Because Im not appointing the solution of this question man

I’m assuming this is Python, which I’m not very good at. I just simply tried to explain if it was a school project.

3 Likes

The way this question is worded really makes it sound like this is for a school assignment. If you provide some proof that it is not we will be happy to help. And if you don’t want to publicly share it feel free to message it to me.

5 Likes

Please, just please, you need to stop asking people to do your work for you; if you have anything ever, like even a friend, giving them code one of us wrote would be deceptive. We do not, nor will we ever, condone this behavior.

EDIT: I can give you a solution, but you will never get far in life if everything, even the smallest “friendly” competition is a forum post away, please try to come up with it yourself, and even then just tell your friend straight that you cannot solve it, take the hit.

2 Likes

Yeah, ok. But i don’t really care. If you think it is. Then I can’t make you ot think it is.

This seems like a basic question. If you’re unable to solve it, I would recommend going through a quick recap of the math function as it might help you get through the problem:

1 Like

sigh ok really sorry for misunderstanding:

import math
a, b = map(int, input().split())
print(math.sqrt(a * a + b * b))
1 Like

You’re asking us to stop doing what we’re supposed to do? What if it was for school/a competition? We just want to make sure we’re not helping anyone cheat.

Then you wouldn’t really get much help here. If you don’t explain that no, you’re not trying to cheat, then we won’t help you. (I know you already did explain, just pointing that out.)

My exact thoughts. You might not even understand the code. If you don’t even try then we won’t help you.

Damn, I don’t even think it I posted this message for this type of answers. Hmm… Like, why are we talking about this. Ah, I see. To leave replit. Ok bye.

Hey @Winstenna,

is this a school assignment?

Temporarily closing this topic due to posts gaining a lot of flags replit I’ve to other topics. Please remember to follow the community guidelines. And please don’t make a new topic to bypass the closing of this one. If you do it will be deleted.

This topic was automatically opened after 6 hours.

Hey there, can we not be like this, as I have given you the help you requested…