Guizero forms not loading

Hi - I have successfully used guizero in repls and I am now getting students to create some forms using guizero, but the forms will not load in the output window.

When I have written my repls, I have been at home and it has worked, but now I am in school on the school network, and the forms are not loading. It’s just the spinning white loading line displayed and the forms never load.

I have looked at other repls on replit using guizero and I cannot get anyone’s to load.

So, could it be a network permission / ports etc problem, or is there a current issue with guizero in replit?

Hi @tally thanks for your query.

I forked your Repl and clicked Run. The guizero UI appeared. I clicked on the first link and saw this:

So I think the issue is with your school blocking the site somehow. Can you try and let me know if this works ok?

Thanks! I tried it at home again and it worked fine, so it must be a school network issue.
I have tried accessing it through and it’s even worse for me. I can’t even access any of the code, never mind run it…

I think you might need to speak to your school’s / region’s tech support to make sure they have unblocked all the sites necessary for Replit to work.