Deployment error in application FLASK

When deploying my application I was getting this error, GPT said it could be a problem with my dependencies but everything is correct. I believe that gunicorn may have a problem, I run the command gunicorn -b app:app to run my application

Hey @LucasAdriSilva!

Can you please provide a link to the repl? This way it is easier for staff and members of the community to help you!

Also see this guide on how to share your code:

1 Like

Right, I tried to create it but I would have to release all my code from what I understand.

Easier with prints,

1st where my Flask is running:

2nd deployment configuration

3rd Application running

4th Error message

Unless you pay for private Repls (as part of core or by themselves), it’s already publicly available on your profile.

@LucasAdriSilva what kind of Deployment are you trying to use? If it is a Static Deployment that wouldn’t work with Flask, and you would need to use an Autoscale Deployment (since it allows backend, or in your case Flask).

1 Like

Yes, I have the paid plan, I’m using Replit to host, but I’m currently having a lot of problems and the platform is very slow to run my codes.

I’m using autoscale:

1 Like