Could not install packages due to an OSError: [Errno 122] Disk quota exceeded

Hi There,

I am trying to install the python package via the shell using the command-

pip install unstructured[local-inference]

That gives error-

I tried to reboot the replit by - kill 1 but that didn’t solve the problem,

Here is more info-

~/askai-2$ df -h /tmp
Filesystem Size Used Avail Use% Mounted on
/dev/conman/conman-repl-filesystem-volume-1286 2.4G 1.8G 582M 76% /tmp

It means that the repl doesn’t have enough storage space to install those packages. By default, repls come with 1 gb of storage, but some python packages are larger than that, meaning that you can’t install them unless you upgrade your plan.

I am already on Hacker plan that provides 5 GB Account Storage so I don’t think thats the problem. @MiloCat

Maybe your package(s) require(s) more than 5 gigs? Could I have the link to the repl?

here you go- @MiloCat

What package are you trying to install?

This one


Oh, sorry. Could you share a screenshot of your resource use?

Account storage or Repl storage?

1 Like

@OSoft @joecooldoo

Look like there is lot of space is available

1 Like

Well I’m not sure -272 MB of RAM is a lot…


is it possible to boost the RAM via the cycles? or I need to upgrade to plan?

Locate the tab that you use to publish your project and name your project. Click any of the boost options.

Still the same error-

@OSoft @QwertyQwerty88

Have you resolved the issue yet? My laptop’s disk (~6GB) is full while pip install "unstructured[local-inference]" too.


Ah, I think i got it. The amount of stuff it would have added (pre-calculations prob, so it would not show on the resources) and pip realized it would be too much, and stopped the installation. Might want to try boosting the repl.