Can't run without print()

Problem description

I can’t run print("Hello World!) without preceding it with print().
I have used Replit for many months, and this occured first time Monday the 22th of April 2024.

Program that doesn’t work:
print("Hello World!)

Result: no output, also no error message.

Program that does work:
print(“Hello World!”)

Results: prints correctly, including the empty line created by print()

Start every program with print()

Replit app on MacBook Pro with M1 (same result in Chrome on same device)

All the ones I’ve tried so far, both new ones (this week) and old ones (that have not had this problem before this week). I use Python.
One example of a repl with this problem:

I have had issues with connectivity, on and off. It has been hard for me to tell whether this has been only with Replit or if there has also been intermittent issues with my WiFi. This may or may not have anything to do with the problem I’m reporting here. I do think I’ve seen more of connectivity issue messages in Replit this week than before. I’m teaching programming, and my students (same classroom, same WiFi) don’t have this problem.

Expected behavior

“Hello World!”

Actual behavior

(no output)

Steps to reproduce

write print(“Hello World!”) and press Run




Mac OS

Device if mobile

MAcBook Pro


Free tier

It seems like the output is printed after a long delay, for all the executions that didn’t seem to give any output, all at once.


1 Like

Hi @JoakimSvahn In the Repl you linked, the entrypoint in the .replit file is:

entrypoint = ""

The file does not have any code so it’s returning blank. This is expected behavior. Do you have any other examples?

I almost wonder if this is another instance of the zoom issue.

1 Like

I am constantly changing the code in this as I’m using it in class. Try to write print(“Hello World!”) and nothing else and press Run.

I suspect this is, as I mentioned above, the zoom issue. Could you try messing with the zoom after printing?

1 Like

Yes! It took me a while to find what you meant by the zoom issue (I thought you referred to the Zoom app). When I zoomed in or out, I got the print out (not directly after running but after running and then zooming in our out. After playing around with zooming, it now seems to work normally again.
I wonder if it makes a difference if the Replit app window is maximized or not? I’ll try to remember to play around with that, too, of the problem returns. For now, I seem to be good.
Thank you for your help! :blush::pray:


FYI, the zoom issues should be fixed now. Let us know if you continue to see any problems!


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.