Bug Report: Replit IDE doesn't work with Safari on Intel mac

I would like to report the problem. Replit IDE doesn’t work on Mac Safari. I have tried clearing all cookies, website data, restart Safari and re-login replit.com again. But it still doesn’t work. On the same mac it works on Firefox or Google Chrome.

MacOS Big Sur 11.7.10
Safari 16.6.1 (16615., 16615)
1.3 Ghz Intel Core i5

1 Like

Hi @ptkrisada , welcome to the forums!
In what way does Replit not work? Could you elaborate?


Console on the right pane says “The Repl is booting…”, but booting has never finished on Intel mac Safari. Firefox and Google Chrome work pretty fine on the same machine.


Could you send a screenshot?


Booting indefinitely… (only Safari on Intel mac)

1 Like

Replit said to have fixed it but I think It could be because of the internet. Or I would recommend reaching out to the Replit support team directly for further assistance. You can wait here till somebody of Replit helps!

1 Like

Could you check network/console logs? Perhaps safari is blocking something.

1 Like

Not internet. Safari can browse any websites pretty fine and very fast except replit. And if it were the internet issue, firefox and google chrome on the same machine wouldn’t be able to access replit.

1 Like

Some time last week, safari could occasionally access replit but now it can’t. And I haven’t change any configuration in safari. If it were safari configuration issue, safari would not be able to access replit (occasionally) last week. It has just happened the last few days. I did remove replit website data and cookies on safari, but it still doesn’t work.

1 Like

That’s why I asked for console/network logs, to cover all bases and see if anything out of the ordinary crops up.


There has been another bug report for this.

Not sure if you want mac console output or safari log output.

  1. mac console output reports nothing, really nothing.
  2. I have 2 safari log files Web Inspector and JS Console, which one do you want? But both of them are not human readable.

Today replit.com happens to work on Intel mac Safari. Wishing it would be persistent, not temporary or occasional.


Hi, i’m having the same issue. It stopped working and then started randomly working again after 5 days. Unfortunately the issue has come back and now it’s been over a week and replit editor still doesn’t boot. I see this is an issue for multiple people but replit doesn’t reply to any of my bug reports.

I also run it on safari on an intel mac.

1 Like

Now replit booting fails again in Safari on Intel mac. It works randomly, not persistent

I want to say that the issue is all the failing websocket connections, but I don’t personally know why they’re failing.

EDIT: Did a bit of googling, found this:

Seems like safari can’t handle empty headers.

(This could also explain it being intermittent, might only send the header if a something needs to be updated)

Looking into it more, looks like this has been around since ~2014, that’s when chromium had to fix the same bug:


But Safari on Intel Mac can sometimes use replit IDE very pretty well. It doesn’t always fail.

1 Like

Again, I reason that this is because:

Which would send a blank header when nothing needs to be updated, causing the issue.