Asyncio module error | replit issue

Hello. There is an issue that I have in replit. Whenever I create a discord bot that has the asyncio module in it, replit gives me the SAME error on all repls. But when I run the same code in VPS, even with asyncio module, everything works normally. How can I fix this issue?

This is the error message that I only experience in Replit, when used asyncio module.

Traceback (most recent call last): File "", line 1, in <module> import discord

File "/home/runner/AutoMeme/venv/lib/python 3.8/site-packages/discord/", line 25, in <module>

from .client import Client File "/home/runner/AutoMeme/venv/lib/python 3.8/site-packages/discord/", line 27

in <module>

import asyncio

File "/home/runner/AutoMeme/venv/lib/python 3.8/site-packages/asyncio/", line 21, in <module>

from .base_events import *

File "/home/runner/AutoMeme/venv/lib/python 3.8/site-packages/asyncio/", li ne 296 future tasks.async(future, loop=self)


SyntaxError: invalid syntax

There appears to be something wrong with that repl, I’d suggest making a new one and copying the file into that.

sorry if my comment is rude or whatever but OP said this ^^^

The error happens on ALL repls. Meaning that making a new one and copying the file into the new one does not work.

I am saying that it happens with all of my repls that have asyncio module, but when I host the script in vps, I don’t get any errors. This is a replit issue. You tell me, how to get rid of this.

They were trying to explain to Cactus that this wasn’t a one-Repl issue.

Oh okay, but is there any solution to this issue?

I’m not sure. I’m checking a few things here first, but then I’ll check your Repl. In the meantime, could you try a “Python (Beta)” template to see if that works?

I am using the “Python Discord Bot” template as always when making a discord bot.

I understand that, but since that template seems to be having issues, could you try the one I suggested?

Alternatively, you could try running poetry update in the Shell, and seeing if that fixes it.

Well i forked the template they were using, and pasted the code and it worked.

Please describe exactly what you do after you fork the template.

Could maybe send the repl link ( the one that worked ) to OP to see if it works or not.