AI assistance is incorrectly turned on for interviews

Bug description:
Replit documentation describes interviewing as a valid, supported use-case: . But using Replit for interviewing has just become impractical, as the candidate can independently turn on and use AI assistance in the shared replit.

Expected vs Current Behavior:
Expected: Interviewer should be able to turn off the AI assistant in a replit.
Current: AI assistance is turned on by default, and even if it’s turned off, the candidate can re-enable it. I want to know what the candidate, not your AI model, is capable of.

Steps to reproduce:
Create a replit, share it in guest mode. Observe guest turn on AI assistance.

Not strictly related, but what is the point of paying for a pro account if the only support option is to post on a public forum?

Screenshot(s)/Screen Recording:

Browser/OS/Device: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/ Safari/537.36


Hi @ElenaFelder1 , welcome to the forums! I’m gonna answer this bit:

Well, you can submit a support ticket at, but the team gets hundreds of thslese support tickets everyday, and it might take longer to get a response. Here, there is Shane who actively responds to bugs and pushes it to the team, so response is faster. Community members like us can also solve your problem so that the staff don’t have so much work.


@ElenaFelder1 I suppose you could check the file’s History (bottom-right corner of the file) and see if chunks of code appear suddenly or are typed normally. If chunks appear suddenly, it’s probably copied and pasted for AI or other sources.
Hope this helps!


We use Replit for interviews primarily. This issue is reason enough for us to have to switch the platform - the interviewer should have control over these options.


This is an issue for us as well. For every interview, we have to ask the candidate to turn off the AI setting before we can start the interview. (Also, the setting to turn off AI keeps moving. First it was behind the AI button, but now it’s behind the Settings button.)

1 Like