You can't run this Repl right now cryptic error

Bug description:

When I try exploring my repl, it works for a few minutes and it halts with the following error.

You can’t run this Repl right now.
It may be temporarily unavailable or it may have violated our Terms of Service.
If you are the owner of this Repl and believe you should be able to run it, you can try again later or contact support.

What I’ve done is to make local path for nixpkgs pinned in since it keeps downloading the nixpkgs source every time I restart the REPL, which is wasting resources for Replit service and wasting time for me to wait until it gets downloaded.

It sometimes works in the beginning for a few minutes and suddenly halts with the above error message. Other times it immediately halts.

Expected vs Current Behavior:
Should work vs not working and error not explaining what I’m doing wrong.

Steps to reproduce:

Bug appears at this link:

Screenshot(s)/Screen Recording:

Browser/OS/Device: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/ Safari/537.36

Replit Profile:

If it DID violate replit’s TOS host on
IF it is just random then call/email replit

What is AFAIK, my repl doesn’t have that file.

I think you are confused:
TOS = Terms Of Service
Railway(.app) = Better replit!

So What does

Railway(.app) = Better replit!


What I can find about is this site

1 Like

Just, Better! :3 I like it more! Just, a little bit $ you get 500 hours/ month For free I ran out pretty quick! If you can you can pay like $3/ month for a good value seems to not use nix. Also, it seems that it is hard to use on mobile devices. Furthermore, it seems it is hard for other users to easily fork the project.

So thank you for your advice but that solution is not what I’m looking for.

Or,,, github pages/Github Actions/Github Codespaces! You are violating the TOS I have used this same thing before on “Sign in to GitHub · GitHub

This doesn’t seem like a ToS violation. Can you tell me what you’re running on this Repl?



Maybe try again later, or it may have sadly is against ToU. If it does not get fixed, please contact Replit.

I hope your repl gets revived

I’m learning haskell so most of the files are exercise functions from github repository and a book called “Learn You a Haskell for Great Good”.

If it is not violating the ToS, then I want to know why that error happens.

It doesn’t seem to violate the ToS. I don’t know why this happens, but I’ve pinged a staff member.

1 Like

Howdy! I took a look at your Repl - seems like it runs from the cover page and forking it I could get it to work too. I think it might have been a temporary bug but just to be safe fork your Repl and use the fork :). Sorry for the inconvenience!


Nope. It is not working. I tried forking.
The above error happens when you click run and test some commands like “1+1” for a few minutes and enter “:q”.

So what I suspect is that my custom nixpkgs folder makes all the havoc.

Without the folder, the reply seems to work fine.

But when there is the folder, Git functionality in replit doesn’t seem to cope well with the folder because it doesn’t show the folder’s title and soon after that Git tab is opened, the repl crashes with the above error.

Putting nixpkgs/ inside .gitignore solved the problem!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.