Why is my deployment not promoting? I couldn't understand the error

My deployment was working fine but it says it can’t promote and I didn’t understand what the error is.

This is a private repl so nobody can see.

1 Like

Could you send the contents of package.json?

1 Like

Ok I will try

{
  "name": "nodejs",
  "version": "1.0.0",
  "description": "",
  "main": "index.js",
  "scripts": {
    "test": "echo \"Error: no test specified\" && exit 1"
  },
  "keywords": [],
  "author": "",
  "license": "ISC",
  "dependencies": {
    "@replit/repl-auth": "^1.0.0",
    "@types/node": "^18.0.6",
    "express": "^4.18.1",
    "node-fetch": "^3.2.6"
  }
}

1 Like

Wait, never mind. I found a way to make it work. It’s working.

1 Like

Hey @UtkMcpe78. It’s great to hear that you’ve fixed your problem, but please provide an explanation to how you did, so that other people who have the same problem know the solution.

1 Like

I found out it was due to the template I was using. I was at first using my Express template, but since my project also involves Bootstrap and jQuery, incompatibility incurred. (That original template: Express.js by UtkMcpe78.)

So, I used Replit’s official template for my project and found it was more versatile. As a result, my deployment worked. (These are two different repls; the one I’m doing right now is the one with Replit’s official template.)

@QwertyQwerty88 The solution is at the top of the post.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.