Why doesn't replit run my freeCodeCamp task code?

Hi, robot. Why replit does not run my freeCodeCamp task code?

please provide more information, including a link to your repl and an error/detailed explanation.

Hello @Constantin2609!

Thank you for your post and sorry that you are experiencing issues. However, we may not be able to help you with this issue if you do not complete the template fields fully.

Without a code excerpt and/or the link to your Repl there won’t be much we can do to help you. A screenshot of the expected output would also be appreciated.

The more information you provide at the start, the easier it will be to identify the bug in your program.

There are template fields for replit help?

Thank you, dragonhunter1. The code is uploaded. I click the ‘Run’ button, it shows, that the code is inder process, and then nothing happens, the 'Run" button getting green again
https://replit.com/@Constantin2609/Budgetpy#main.py

That is because your code does nothing other than setting some things up. Try initializing your class, calling some functions, and printing some things.

I have applied many times the class, but to no avail

Hello and Thank you, Firepup650! The link is this https://replit.com/@Constantin2609/Budgetpy#budget.py

Finally, it did work

1 Like

First of all, this is python 3, not 2, so class Category(object): should be class Category:. And secondly, sorry i did not read your code correctly, you do call it. Also, variable names are usually not capitalized by default. I will continue looking at your problem.

Edit nvm, you fixed it.

No, I might have pasted a canned response, lol.

1 Like

Thanks for your comment. Just seen it. Still not familiar enough with this site

That’s not just the site, that’s newer python in general IIRC.

1 Like