Whitelisting Replit IP for api request

Question: Cannot send an api request as a whitelisted IP
I wanted to try sending an API request so i can turn on/off uptime monitors, but when i tried to use the Whitelist IP option, it says Request failed with status code 403 (works if without Whitelist IP), i already put my whitelisted replit by pinging it (ping api-test.davedzrod.repl.co) and putting that ip, but it doesnt work. Is this a replit issue or the uptime monitor API’s?