When I press these button while coding with editor, it will do it twice in once. how can I set it back

**Question:the backspace and enter **

**Repl link/Link to where the bug appears:every new editor **

Screenshots, links, or other helpful context:when I press these button while coding with editor, it will do it twice in once. how can I set it back

code snippet

Hi @chen95279487 , welcome to the forums!
Is your internet connection stable?

Yes ,the internet connection is stable in usual.

Can you reproduce this bug on any other platform or software?

@chen95279487 Does this error happen on any other platform, e.g. Notepad, Word etc?

nope, it only happen on replit.

Are you using an external keyboard if you’re on a laptop?

i don’t use external keyboard on laptop.
and this might happen on each device.

I used AI to help organize my response :

Considering the information you provided, it’s less likely that the issue is related to hardware. I observed in the video that the name of your Repl is not in English, which suggests that you may be located outside of North America.

If that is the case and you’re using the North American server, it’s possible that connecting to a server in a different region could introduce latency or delays in data transmission.

(If this is not the case then you can just ignore the rest of this post.)

Even if your internet connection appears to be stable, latency can still occur due to factors like the physical distance between your location and the server, network infrastructure quality, and overall network conditions. This latency can lead to unexpected behavior, such as duplicated backspaces in the code editor.

To further investigate this, you can perform specific latency tests or traceroute tests to assess the network latency between your device and the Replit server. This can provide additional insights into whether latency is a contributing factor to the duplicated backspaces issue.

It’s also worth checking if there are any regional or language settings differences between your device and the server. Mismatches in keyboard layouts or language settings can potentially cause issues with key mappings and unintended behavior.

Remember that while using a server in a different region can introduce complications, it doesn’t necessarily mean it is the sole cause of the duplicated backspaces issue. Other factors like software configuration or specific bugs in the code editor should also be considered during the troubleshooting process.

(Removed part of post that just suggested you reach out to Replit’s support forums, since you are already doing that)

Is there any chance you adjusted the Repeat delay or Repeat rate in your keyboard properties?

Keyboard Properties 2023-11-15 03-35-42

It changes the speed at which the letters are deleted when I press and hold down the backspace key.

It also acts the same way for writing something not just backspacing but only backspacing is shown in the gif.
(Instead of deleting the letters it would be repeating them faster or slower.)

This might explain why your key presses are sometimes being duplicated unexpectedly.

If you have.

You can use the ‘run’ command control keyboard to access the settings for ‘Repeat Delay’ and ‘Repeat Rate’ shown in the gif from above.

Repeat delay is how long it takes for your keyboard to start repeating the key you are holding down.
(press and hold). (**delay**) .......

Repeat rate is how fast the key is repeated after the delay.
Fast repeat rate
(press and hold).(*delay*).|.|.|.|.|
the . represents the key being repeated and the |'s represents a delay between the repeated characters after the initial delay.
Slow repeat rate
(press and hold).(*delay*).||||.||||.||||.||||.||||
It repeats at a slower rate after the delay.
again, the . represents the key being repeated but the multiple|'s represent a longer delay between the repeated characters, after the initial delay.

if not then you can ignore this.

Semi-related maybe

I had a problem with certain video games I was playing, where they would suddenly start moving even when I wasn’t holding the key down, and then not stop until I pressed that key again.

I thought it could have been sticky keys but it wasn't so I kept looking and that's how I found these settings, I adjusted them and it seemed to have fixed my issue. If you have adjusted these settings for whatever reason or another it may explain why you are sometimes getting duplicated backspaces.

Otherwise maybe,

I noticed that your cursor is customized. Could you let us know which operating system you are using? Understanding this might help troubleshoot any potential compatibility issues with Replit’s IDE.
If this is the case, I personally wouldn’t be able to help you, but it could help the Replit Support Team to troubleshoot your issue.

I’m on Windows 11 now, and then I’m sure I didn’t adjust those settings because I’ve never even heard of that before.

And i just test if it happen on others browser. i find it won’t happen with chrome but edge.

Hi @chen95279487 !
Does this bug appear on any other website using Edge?
Either way, you should switch to Chrome so as to not encounter this bug.