When I click "run" on the top, I'm getting an error message on the right "... sent an invalid response." what is the reason for this?

I’m also unable to view other people’s Replits. I’m getting the same type of error. Any ideas on how to resolve this? Thank you in advanced!

Try opening the website in a new tab. Does that work?
This is a bug that has been atound recently. The Replit Team are trying to fix it it.

1 Like

Hey @WilsonLee8 welcome to the forums!

Try doing what @NateDhaliwal said. Also you haven’t closed the <html> tag, nor added a <body> tag. So here is your fixed code.

<!DOCTYPE html>
        <h1>I love 90s design</h1>
1 Like

Which is technically okay, it’s just bad practice, and results in harder to read code.


Hey Nate, I’ve tired opening this in a new tab and in a new browser but it’s still no good… Have you faced this issue before?

No. I have not encountered it before… can you try forking this repl and see if the forked version works?

Hi Nate, I published it, forked it and I’m still getting the same error

I’ve been consistently getting this error across multiple browsers and accounts for the last couple of weeks. The only workaround I found is to open the preview window in another tab, which is not ideal. Is there any fix?

Hey @XaviRamirez @WilsonLee8!

Could you please give a link to your Repl so we can look into it further?


It’s pretty much any repl. Most recently, it happened on the repl embed in repl.it’s matpotlib docs: https://docs.replit.com/tutorials/python/creating-interactive-python-plots-matplotlib

Clicking though doesn’t help. Forking causes all sorts of other issues…

@XaviRamirez what other issues? Can you show one of your Repls? The link doesn’t work for me, it might not work at all.

@SalladShooter Here’s the a link to the fork: https://replit.com/@XaviRamirez/docs-matplotlib

Great news it seems to work now! The previous issues were that it seemed stuck on the “Migrating to Nix” step for >20mins and when that finished, the output didn’t work.

As for the original problem, it seems to happen to pretty much every HTML/JS/CSS repl.it I stumble across. For example: https://replit.com/@yevbar/Website-Workshop1

Same issue: