Weird NIM failure

I just opened and run a repl that was working find (using NIM) and i got the weirdest of errors:

 nim c -r main.nim
     Error: /__w/choosenim/choosenim/src/choosenimpkg/proxyexe.nim(62) proxyexe
        ... /__w/choosenim/choosenim/src/choosenimpkg/proxyexe.nim(40) main
        ... /__w/choosenim/choosenim/src/choosenimpkg/proxyexe.nim(37) getExePath
        ... getAppFilename failed. (Error was: Unable to read /home/runner/.choosenim/current. (Error was: No installation has been chosen. (File missing: /home/runner/.choosenim/current)))
      Info: If unexpected, please report this error to

As I am now playing with NIM, i have no clue what this is except something might be broken …

I just opened my other NIM repl and same error … something is broken.

1 Like

Does kill 1 fix it? If not do cat BOOTLOG and give the results.

I experience it on all nim repl, even if I create e new one, fork or do kill 1.

Results is

1 Like

Link to the repl please? And this is happening with all choosenim repls?

Debugging the template right now!

1 Like

@whileTRUEpass Temp fix, put devel in nimv.txt instead of stable. Still working out the issue.

channel = “devel-22_11” ?
If this does not work. Would be very curious to know what is going one once you figure it. Out of curiosity

no, where did you even find that? Each choosenim repl comes with a file called nimv.txt, and inside it should say “stable”, you have to change that to “devel”

In the .replit. Will change and try again. Thanks.

1 Like

Same thing. Same error.

UPDATE: works now with devel


Ok, i added a temp fix to the template, so new repls should work on stable. And I also found the source of the issue:

  • Nim, the language, released version 2.0
  • Choosenim, the installer, does not know wtf to do with a number above >1.9.9 or smth
  • It finds that the stable version is 2.0, and it breaks itself, thankfully post-install, so you can still use it


Man. I hate what that happens. New version breaking things … I had it once with go, they released a breaking versions and our clients decided to recompile their code without asking and all went berserk.
After that we took the source code private …

marked as solution and thanks a lot !


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.