Weird characters and new lines being added while I type

Problem description:
Weird characters and new lines keep being added while typing. Deleting the characters just adds more.

Expected behavior:
Typing code with no issue

Actual behavior:
While typing, an unrecognised character gets added to the start of the line. At the same time, new lines are being made from the bottom. Deleting the characters adds more.

Steps to reproduce:

Bug appears at this link:

OS: Android 13
Device (Android, iOS, n/a leave blank): Android
Plan (Free, Hacker, Pro Plan):

Wow that’s… weird

I usually code in iOS and sometimes android, but never seen it before.
It is like some virus is messing your code or smh

Have you tried to run your code with these weird characters in your file? Or maybe force restart the replit app by removing it from background process

1 Like

Yup tried both of those, even restarted my device. A recent scan tells me there seems to be no virus or anything. Also i did see a review on the playstore menioning something similar to what was happening to me so i don’t think this was an isolated incident

This was extremely common back then, and I still encounter it a few times now.

It’s not caused by viruses or anything btw.

What kind of Android? We had a problem similar to this related to a Samsung OS bug. Are you updated to the latest version of Android?


Yes I’m using the samsung tab 8 on the latest version of android

What version of the app are you on?